2017-12-11 3 views
7

android/app/build.gradle i vartepki Yerli-fbsdk hatası: attr 'android: keyboardNavigationCluster' Hayır kaynak adı verilen maçları bulundu benim tepki yerli projede

... 
compileSdkVersion 26 
    buildToolsVersion "26.0.1" 

    defaultConfig { 
     applicationId "..." 
     minSdkVersion 16 
     targetSdkVersion 26 
     versionCode 1 
     versionName "1.0" 
     ndk { 
      abiFilters "armeabi-v7a", "x86" 
     } 
    } 

... 

dependencies { 
    compile project(':react-native-fbsdk') 
    compile project(':react-native-vector-icons') 
    compile project(':react-native-splash-screen') 
    compile project(':react-native-spinkit') 
    compile project(':react-native-orientation') 
    compile project(':react-native-maps') 
    compile project(':react-native-android-sms-listener') 
    compile fileTree(dir: "libs", include: ["*.jar"]) 
    compile "com.android.support:appcompat-v7:26+" 
    compile "com.android.support:design:26+" 
    compile "com.android.support:recyclerview-v7:26+" 
    compile "com.android.support:cardview-v7:26+" 
    compile "com.facebook.react:react-native:+" // From node_modules 
    compile("com.crashlytics.sdk.android:crashlytics:[email protected]") { 
     transitive = true; 
    } 
} 
... 

ama her zaman olsun

satır 19 arayan YOUR_PROJECT/node_modules/tepki yerli-fbsdk/android/build.gradle

gitmek

<mypath> .../node_modules/react-native-fbsdk/android/build/intermediates/res/merged/release/values-v26/values-v26.xml:15:21-54: AAPT: No resource found that matches the given name: attr 'android:keyboardNavigationCluster'. 

<mypath> .../node_modules/react-native-fbsdk/android/build/intermediates/res/merged/release/values-v26/values-v26.xml:15: error: Error: No resource found that matches the given name: attr 'android:keyboardNavigationCluster'. 


:react-native-fbsdk:processReleaseResources FAILED 

FAILURE: Build failed with an exception. 

* What went wrong: 
Execution failed for task ':react-native-fbsdk:processReleaseResources'. 
> com.android.ide.common.process.ProcessException: Failed to execute aapt 
+0

değiştirmek Should _compileSdkVersion = 26_ ve _buildToolsVersion = '26 .0 .1'_ tüm bağımlılıklarda build.gradle dosyaları @Sunrising –

+0

Düzenlemeliyim node_modules içindeki dosyalar @SyedZainAli – Sunrising

+0

Evet, node_modules/fb SDK –

cevap

27

Go için çalışıyorum. Başka bir hata aşağıda gibi varsa

allprojects { 
    repositories { 
     ... 
     configurations.all { 
      resolutionStrategy { 
       force 'com.facebook.android:facebook-android-sdk:4.28.0' 
      } 
     } 
    } 
} 

:

Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Colored'`.

Deneyebilirsin:

allprojects { 
    repositories { 
     ... 
     configurations.all { 
      resolutionStrategy { 
       force 'com.facebook.android:facebook-android-sdk:4.22.1' 
      } 
     } 
    } 
} 

Kaynak: rafaesc

+2

bu iyi çalışıyor! – Crysfel

+0

Mükemmel, teşekkürler! – adlondon

5

:

dependencies { 
    compile 'com.android.support:appcompat-v7:25.0.0' 
    compile 'com.facebook.react:react-native:+' // support react-native-v0.22-rc+ 
    compile('com.facebook.android:facebook-android-sdk:4.+') 
} 

değiştirme derleme ('com.facebook.android:facebook-android-sdk:4+')

('com.facebook.android:facebook-android-sdk:4.28.0') hazırlanması için android/build.gradle dosyası ve 4.28.0 için fbsdk Versiyon kısıtlamak:

O tepki-Yerli Projesibeni

+0

Evet! Benim için çalıştı. Çok teşekkür ederim, bana çok zaman kazandırırsınız –

+0

. Bu benim için de çalıştı. Şimdi, 'varsayılan' bulunamadı 'adıyla Yapılandırma' derken başka bir hata mesajı alıyorum. –

+4

Bu kötü bir çözümdür, yalnızca bağımlılıklarınızı güncelleyene kadar çalışır ve node_modules üzerine yazılır. Ayrıca, node_modules öğelerinizin kaynak kontrolünden hariç tutulduğunu düşünürseniz, başka kimse projenizi çalıştıramaz. – Sam

İlgili konular