2017-12-22 50 views
5

Burada başlık olarak kullanılan iletiyle uygulamada çok sayıda çökme gördük. Neredeyse tüm çöküntüler OnePlus cihazlarında ve çoğu da Android Oreo'dan gelen Oxygen OS sürümünde. Bunu başka gören var mı? com.android.webview de android.webkit.WebViewDelegate.getPackageId de com.android.chrome (WebViewDelegate.java:164) :Paket bulunamadı: com.android.chrome

java.lang.RuntimeException: bulunamadı Paketi aşağıdaki StackTrace olduğunu com.android.webview.chromium.se.run de com.android.webview.chromium.WebViewChromiumFactoryProvider.h (WebViewChromiumFactoryProvider.java:177) de .chromium.ig.L (WebViewDelegateFactory.java:16) (WebViewChromiumFactoryProvider.java : 5) android.os.Handler.handleCallback'de (Handler.java:789) android.os.Handler.dispatchMessage'da (Handler.java:98) android.os.Looper.loop (Looper.java:164 adresinde) ) at android.app.ActivityThread.main (ActivityThread.java:6809) java.lang.reflect.Method.invoke adresindeki (Yerel Yöntem) at com.android.internal.os.Zygote $ MethodAndArgsCaller.run (Zygote.java : com.android.internal.os.ZygoteInit.main at 240) (ZygoteInit.java:767)

Düzenleme: 18 Şubat 2018: aldık ekibimiz One Artı 5T (OnePlus A5010) Birkaç hafta önce ve bizim app çalışırken herhangi bir sorun görmedim. Cihaz, Android 7.0'ın OxygenOS çatalı önceden yüklenmiş olarak geldi. Ancak, bugün cihaz Android 8.0.0 (OxygenOS 5.0.3) güncelleme bildirimini aldı ve güncellemeyi başarıyla yükledikten sonra, uygulamamız aynı stacktrace ile çöküyor. Bu kaza, kullanıcı tabanımızı korkunç bir şekilde etkiliyor. Herhangi bir yardım takdir edilecektir.

+0

Krom takılı mı? Yoksa alternatif bir tarayıcısı var mı? –

+0

Halen sipariş edilen OnePlus cihazının beklemesi cihazla ilgili soruları yanıtlayamıyor. Ancak kaza, OnePlus cihazlarıyla yaklaşık 480 kullanıcı etrafında 2500 kere gerçekleşti. –

+0

belki kromun izin vermediğiniz özel bir izne ihtiyacı var, chrom –

cevap

0

Muhtemelen, eski bir krom sürümü yüklemiş olmanız için güncelleştirmeyi deneyin.

+0

Hayır olur, telefon her zaman kromun en son sürümüne sahipti. Ayrıca, daha eski bir krom sürümünün uygulamayı eksik bir krom paketi hatasıyla kapatmaması gerektiğini düşünüyorum. –

İlgili konular