2017-10-31 9 views
5

böyle hata var ben 3.0 Android stüdyo güncellemek ve bu instructionAndroid stüdyo 3.0 Hata SHA-256 org/jacoco/ajan için hatayı sindirmek var/os/RT.class

izleyerek projemi taşıdıktan sonra :

* What went wrong: 
Execution failed for task 
':app:transformClassesWithFirebasePerformancePluginForDevDebug'. 
> SHA-256 digest error for org/jacoco/agent/rt/RT.class 

Ben izlenir ve kök neden build.gradle dosyasında bu kodun geldiğini gördük.

debug { 
    ... 
    // Run code coverage reports by default on debug builds. 
    testCoverageEnabled = true 
} 

Bu kod satırını yorumladığımda, proje iyi oluşturdu. Android Studio 2.3 kullandığımda bu sorunla karşılaşmadım.

Bazı ilgili konuları araştırdım ve birisinin devre dışı bırakma anında çalıştırmanın çözüleceğini söylediğini ancak maalesef benim durumum için çalışmadığını öğrendim.

Doz Herkes bu sorunu çözmek için herhangi bir öneri var mı?

Teşekkür

cevap

4

GÜNCELLEME 2:

Firebase destek hâlâ düzeltme dışarı haddelenmiş değil ama firebase-perf ve jacoco son sürümleriyle bugün bunu denedik ve işe yarıyor diyor.

GÜNCELLEME 1: Java 1.8 support etkinleştirildiğinde

firebase-perf

jacoco ile çalışmaz. Firebase destek ekibi bunu çoğaltmayı başardı ve araştırıyor.

Orijinal Mesaj:

Bu firebase-perf eklenti etkinleştirildiğinde tetiklenecek görünüyor. Firebase ekibiyle bir hata yaptım ve bir cevap alırsam güncellenir.

Geçici bir çözüm olarak, yalnızca apply plugin ... firebase-perf numaralı öğeyi yorumlamalısınız. Automatic Traces'u devre dışı bırakır, ancak @AddTrace ve newTrace hala çalışmalıdır. Benim durumumda testCoverageEnabled yılında

şartlı bir proje özelliği göre ayarlanır ve ben kapsama değerlendirirken için Firebase-perf eklentisi gerek yoktu, bu yüzden sadece eklenti devre dışı:

if (!project.hasProperty('coverageRun')) { 
    apply plugin: 'com.google.firebase.firebase-perf' 
} 
// <...> 
if (project.hasProperty('coverageRun')) { 
    testCoverageEnabled true 
} 
İlgili konular