2017-12-07 21 views
6

Tizen Studio'yu kurmak üzereyim ve ayrıca Aşınma ve Cihaz için Emülatörlere de ihtiyacım var. Ama ne yazık ki libpng12-0 gerektirir, libpng16-16 zaten yükledim.Emulator gerektirir eski libpng12-0

Tizen Installer'a, son son olanlara zaten sahip olduğunu nasıl söyleyebilirim ..?

+0

Bu bağlantıdaki talimatları uyguladınız mı (https://developer.tizen.org/ko/development/tizen-studio/download/installing-tizen-studio?langredirect=1)? Geliştirme PC'niz tüm bu önkoşulları karşılıyor mu (https://developer.tizen.org/ko/development/tizen-studio/download/installing-tizen-studio/prerequisites)? –

cevap

3

Son son libpng versiyonunu kullanabileceğim bir çözüm tercih ederim 16. Ama ne yazık ki yapamam.

Tüm önkoşullar burada karşıladım: https://developer.tizen.org/ko/development/tizen-studio/download/installing-tizen-studio/prerequisites - boşuna. Yukarıdaki gibi libpng12 bulamıyor.

henüz kirli geçici çözüm yaptı: Buradan https://packages.ubuntu.com/xenial/libpng12-0 deb paketini indirip sudo dpkg -i libpng12*.deb

EDIT'e yüklü: Bu çözüm başka hata neden olurken sinaptik güncellemeler depoları:

depo ' http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng xenial Release 'herhangi bir Sürüm dosyasına sahip değil.

1

Ralf Wickum'un cevabı doğru olanıdır; libpng12'yi indirme ve onu sudo komutuyla yükleme veya sadece çift tıklayarak. Ayrıca libpng12 * dosyalarını kendileri almayı denedim, fakat bu işe yaramaz; tizen yükleyici, kütüphane değil paketinin varlığını kontrol eder.

Depo sorunu, geçici çözümle ilgisi yoktur. Bu, /etc/apt/sources.list.d/ dosyasındaki /etc/apt/sources.list dosyasındaki dosyalardan birine eklediğiniz bir satırdır. Satırı kaldırın ve sudo apt güncellemesini çalıştırın ve her şey yolunda olmalıdır.